Copper Talk » Manufacturers Questions » RF Limited / Magnum » S-6 mic jack not working « Previous Next »

Author Message
Top of pagePrevious messageNext messageBottom of page Link to this message

Jdgwyo
New member
Username: Jdgwyo

Post Number: 9
Registered: 3-2007
Posted on Friday, November 06, 2009 - 1:17 am:   Edit Post Delete Post    Move Post (Moderator/Admin Only)

Hello all,
wondering if anyone might know why my front jack on my 6 will only dead key and my radio is cutting out using the side jack. tried multiple mics including 2 cobra mics and a rk56, all which have worked on radio before. none of those will modulate on either jack but still work on buddy's omega. the only 2 mics i have that will make the side jack modulate are my 636 and road devil but as i said it cuts in and out. i have looked at wires and connections and nothing looks bad. any ideas?

thanks jerry
Top of pagePrevious messageNext messageBottom of page Link to this message

Tech808
Moderator
Username: Tech808

Post Number: 17205
Registered: 8-2002


Posted on Friday, November 06, 2009 - 7:32 am:   Edit Post Delete Post    Move Post (Moderator/Admin Only)

Jdgwyo,

Without seeing your radio, I would suggest that you contact Sam Lewis / Magnum direct for help/advice to solve/resolve your problem.

Copper Talk
Manufacturers Questions
RF Limited / Magnum
How do I contact Sam Lewis / RF Limited/MAGNUM International direct?

Lon~Tech808
N9CEF
CEF#808~CVC#002

Radio Enthusiast!

Add Your Message Here
Post:
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Password:
Options: Enable HTML code in message
Automatically activate URLs in message
Action: